karzilla: a green fist above the word SMASH! (Default)
Karzilla, Destroyer of Bugs ([staff profile] karzilla) wrote in [site community profile] dw_maintenance2017-02-12 11:07 pm

Code push imminent!

We're about to pull the lever on tonight's code push! I'll update this post when it's finished. For a reminder of what to expect, check the previous post for the list of changes.

Update: All done! Comment here if you notice any issues that need our attention.
zaluzianskya: shion tsuchiya looking like a nerd (10-4!)

[personal profile] zaluzianskya 2017-02-13 05:58 am (UTC)(link)
The image management is nice!

...Okay I forgot that reaction image was a gif. NEVERMIND.
Edited 2017-02-13 05:59 (UTC)
magicalduck: (embarassment)

[personal profile] magicalduck 2017-02-13 06:06 am (UTC)(link)
I've desperately been trying to upload another icon to my account for like the past 10 minutes hAHA ;u;
noneofyours: (Default)

[personal profile] noneofyours 2017-02-13 06:28 am (UTC)(link)
Same problem here, thanks for looking into this!
nrgburst: (alison effed it)

[personal profile] nrgburst 2017-02-13 07:17 am (UTC)(link)
Ditto this issue!

(no subject)

[personal profile] kaberett - 2017-02-13 08:43 (UTC) - Expand

(no subject)

[personal profile] laughitup - 2017-02-13 13:35 (UTC) - Expand

(no subject)

[personal profile] kaberett - 2017-02-13 16:50 (UTC) - Expand

(no subject)

[personal profile] nrgburst - 2017-02-13 13:55 (UTC) - Expand

(no subject)

[personal profile] kaberett - 2017-02-13 16:50 (UTC) - Expand

(no subject)

[personal profile] drunk_scraplet - 2017-02-13 15:02 (UTC) - Expand

(no subject)

[personal profile] ecclesiophobic - 2017-02-13 16:07 (UTC) - Expand

(no subject)

[personal profile] kaberett - 2017-02-13 16:50 (UTC) - Expand

(no subject)

[personal profile] 15minuteslatewithcoffee - 2017-02-13 15:32 (UTC) - Expand

(no subject)

[personal profile] kaberett - 2017-02-13 16:51 (UTC) - Expand

(no subject)

[personal profile] thetinydemon - 2017-02-14 22:00 (UTC) - Expand
my_tucker: (Default)

[personal profile] my_tucker 2017-02-13 08:03 am (UTC)(link)
Thanks for all the hard work guys. It's exciting to have image hosting now!

I think I've found a small problem though. I uploaded an image and found I could post it to my journal when I copy and paste the code generated in the "Image Embed" field to the HTML tab on the post entry page, but it wouldn't seem to post with the code generated in the "Thumbnail Embed" field.

I figured out the problem - the last bit of the code is missing a quotation mark (') in the "Thumbnail Embed" field as per this example: alt='' title='Train/> instead of alt='' title='Train'/> as per the "Image Embed" field code. I find when I add the missing quotation mark it works. It's the same for all sizes selected in the "Thumbnail Embed" field.

I've only uploaded the one image so far for testing purposes, so I'm not sure if it's just that one or all images. Hope that helps anyway...

P.S. I'm quite new to Dreamwidth and I have to say the site has such a nice feel. It's very refreshing!
mark: A photo of Mark kneeling on top of the Taal Volcano in the Philippines. It was a long hike. (Default)

[staff profile] mark 2017-02-13 08:13 am (UTC)(link)
Eagle eyes!

Just pushed out a temporary fix that should help for now. Thanks, let us know if you see anything else!

(no subject)

[personal profile] my_tucker - 2017-02-13 08:20 (UTC) - Expand

(no subject)

[personal profile] my_tucker - 2017-02-13 08:23 (UTC) - Expand

(no subject)

[personal profile] azurelunatic - 2017-02-13 08:27 (UTC) - Expand

(no subject)

[personal profile] kaberett - 2017-02-13 08:41 (UTC) - Expand

(no subject)

[personal profile] my_tucker - 2017-02-13 09:37 (UTC) - Expand

(no subject)

[personal profile] my_tucker - 2017-02-13 23:34 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-13 23:45 (UTC) - Expand

(no subject)

[personal profile] my_tucker - 2017-02-13 23:57 (UTC) - Expand
catodon: (jonas)

[personal profile] catodon 2017-02-13 09:45 am (UTC)(link)
Many thanks for really useful improvements and especially for unicode support!
ninetydegrees: Text: Thank you in different languages (thanks)

[personal profile] ninetydegrees 2017-02-13 01:23 pm (UTC)(link)
Particularly loving all the changes made to the Image interface. Thanks everyone for the hard work!
1179875: Shiro run to the escape pod season two episode three (Default)

[personal profile] 1179875 2017-02-13 04:14 pm (UTC)(link)
Thank you!
infernalblood: (Default)

[personal profile] infernalblood 2017-02-13 06:28 pm (UTC)(link)
Another one here where the upload function doesn't work no matter how many tries. URL upload does work though. (Unfortunately it seems like Hollow-Art does watermark their images somehow when uploaded via URL. I mean I was going to leave credit anyway but this is a bit too much covering)
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2017-02-13 08:23 pm (UTC)(link)
I'm sorry about this! Our current working theory is that it's an unintended side effect of a few backend changes, and we'll try to get it fixed as quickly as we can.

(no subject)

[personal profile] infernalblood - 2017-02-13 22:00 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-13 22:19 (UTC) - Expand

(no subject)

[personal profile] infernalblood - 2017-02-13 22:28 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-13 22:57 (UTC) - Expand

(no subject)

[personal profile] infernalblood - 2017-02-13 22:59 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-13 23:27 (UTC) - Expand
infiniteviking: A bird with wings raised in excitement. (6)

[personal profile] infiniteviking 2017-02-14 01:24 am (UTC)(link)
Thanks for the smooth code push! :) And especially for the image management. Awesome!

This might be me just now noticing, but I've got a "connection is not secure" icon in my url bar all over Dreamwidth, with a red-lined lock icon beside it as I log in. It's showing as secure for a friend who's on Chrome (which I'm not). Is this an issue, or was it always like that?
Edited 2017-02-14 01:25 (UTC)
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2017-02-14 02:42 am (UTC)(link)
Hm, what browser are you using?

(no subject)

[personal profile] infiniteviking - 2017-02-14 02:53 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-14 04:32 (UTC) - Expand

(no subject)

[personal profile] infiniteviking - 2017-02-14 11:10 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-14 13:33 (UTC) - Expand

(no subject)

[personal profile] infiniteviking - 2017-02-14 14:52 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-15 05:13 (UTC) - Expand

(no subject)

[personal profile] marahmarie - 2017-02-15 04:46 (UTC) - Expand
primwood: Cat Smiling with Strawberry (Default)

[personal profile] primwood 2017-02-14 02:44 am (UTC)(link)
I was told that DW would now have an image database and that I'd be able to upload photos into it. All I see is the ability to put in a URL which is not the same thing, and something that was there before. Am I missing something?
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2017-02-14 04:27 am (UTC)(link)
Yup, in-browser upload is Upload Images and managing uploaded images is Bulk Edit Images. (The former is linked under the 'Create' menu and the latter under the Organize menu!)

(no subject)

[personal profile] primwood - 2017-02-15 00:54 (UTC) - Expand
sparkythegeek: (8 Ball)

[personal profile] sparkythegeek 2017-02-14 03:33 pm (UTC)(link)
I'm finding I can't upload a new icon from a file. Even though it shows it is selected, it says I need to choose one to upload. FYI! :)
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2017-02-15 05:23 am (UTC)(link)
We're working on trying to fix this! The thing we thought would fix it did not fix it. :) Sorry; hang tight and it will be fixed as soon as we can.

(no subject)

[personal profile] sparkythegeek - 2017-02-15 13:10 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-15 13:25 (UTC) - Expand

(no subject)

[personal profile] sparkythegeek - 2017-02-15 13:28 (UTC) - Expand
my_tucker: (Default)

Icon uploader not working

[personal profile] my_tucker 2017-02-14 07:18 pm (UTC)(link)
I'm having the same issue as sparkythegeek above. I can upload icons from a URL, but not from a file. I read it was a known issue, but on the support board there were replies to people posting about the issue that says a fix has gone live. The fix does not appear to have made a difference for me. I have tried two different browsers (chrome & FF), two different DW accounts, multiple icons, but nothing is working. I've also cleared the cache on both browsers and performed a DNS flush. No effect.

When I choose a file, it appears to accept it - the name of the file appears next to the browse button, then I add my keyword and comment, and then I press "proceed". It looks like it's going to work (as in there are no error messages) but then the page goes back to how it was with the upload area blank again and no icon added.
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

Re: Icon uploader not working

[staff profile] denise 2017-02-15 05:24 am (UTC)(link)
Sorry, we're working on fixing this! (Icon uploading is a code path that is very old and very complicated, and we keep finding more hidden problems...)

Re: Icon uploader not working

[personal profile] my_tucker - 2017-02-15 06:40 (UTC) - Expand

Re: Icon uploader not working

[staff profile] denise - 2017-02-15 09:42 (UTC) - Expand
runpunkrun: drawing of two astronauts floating in space and holding hands (i love the whole world)

[personal profile] runpunkrun 2017-02-14 07:50 pm (UTC)(link)
So excited about the new file management interface!

Now where's the option to turn on https? I've been browsing DW that way for a while, with the bookmark for my reading page pointing to https, but Firefox gives me the lock with the yellow caution sign, saying "parts of this page are not secure (such as images)." Is that a known thing?
ninetydegrees: Drawing: a girl's face, with a yellow and green stripe over one eye (Default)

[personal profile] ninetydegrees 2017-02-14 09:20 pm (UTC)(link)
Can't answer the second question but the option to turn on https is on the beta page: https://www.dreamwidth.org/beta :)

(no subject)

[personal profile] runpunkrun - 2017-02-14 21:28 (UTC) - Expand
my_tucker: (Default)

[personal profile] my_tucker 2017-02-14 09:58 pm (UTC)(link)
runpunkrun - re the yellow caution sign on firefox. That happens to me on all the pages I have images from photobucket appearing on. That could be a tiny icon, a background image, a mood theme, not just an image I've included in an entry. Basically the Dreamwidth content is all secure but the images I have hosted on photobucket are not (I note photobucket do not use https encryption). If I block images with my ImageBlock extension & refresh the page, the yellow caution sign disappears, which proves the hosted images are the culprit. As for the implications of this, this article may be helpful: https://support.mozilla.org/t5/Protect-your-privacy/Mixed-content-blocking-in-Firefox/ta-p/10990
Edited 2017-02-14 22:02 (UTC)

(no subject)

[personal profile] runpunkrun - 2017-02-14 22:09 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-15 05:17 (UTC) - Expand

(no subject)

[personal profile] my_tucker - 2017-02-15 06:49 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-15 09:46 (UTC) - Expand

(no subject)

[personal profile] my_tucker - 2017-02-15 10:01 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-15 10:04 (UTC) - Expand

(no subject)

[personal profile] my_tucker - 2017-02-15 10:20 (UTC) - Expand

(no subject)

[personal profile] ninetydegrees - 2017-02-15 12:23 (UTC) - Expand
sparkythegeek: (Default)

[personal profile] sparkythegeek 2017-02-20 02:47 am (UTC)(link)
Hi again! Is there any way to adjust the image uploader to allow sizes larger than icon-ish? I had uploaded a picture with a larger dimension than that, but it uploaded as 100x100-ish (it might've been 100x149 at the most).
denise: Image: Me, facing away from camera, on top of the Castel Sant'Angelo in Rome (Default)

[staff profile] denise 2017-02-20 02:55 am (UTC)(link)

There's no size restriction on image file uploads, so if you're having problems, doublecheck your image size to make sure you have the right version and then open a support request so someone can look into it (with a link to the image, uploaded somewhere else on the internet)?

(no subject)

[personal profile] sparkythegeek - 2017-02-20 02:55 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-20 03:06 (UTC) - Expand

(no subject)

[personal profile] sparkythegeek - 2017-02-20 02:58 (UTC) - Expand

(no subject)

[staff profile] denise - 2017-02-20 03:07 (UTC) - Expand